2017 Multi-University Training Contest - Team 1 & hdu6043 KazaQ's Socks

题目:                                      KazaQ's Socks


Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k -th day.
 

Input
The input consists of multiple test cases. (about 2000 )

For each case, there is a line contains two numbers n,k (2n109,1k1018) .
 

Output
For each test case, output "Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2

思路:签到题。自己动手写一下就能找到规律。比如n=3:12312131213......n=4:


CODE:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    __int64 n,m=1,k;
    while(~scanf("%I64d%I64d",&n,&k)){
        printf("Case #%I64d: ",m++);
        if(k<=n) printf("%I64d\n",k);
        else{
                if(n==2) printf("%I64d\n",k%2==0?2:1);
                else{
                        k-=n;
                        k=k%(2*n-2);
                        if(!k) printf("%I64d\n",n);
                        else if(k<n) printf("%I64d\n",k);
                        else printf("%I64d\n",k-n+1);
                }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值