5-14 Insertion or Heap Sort (25分)

5-14 Insertion or Heap Sort   (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 100100). Then in the next line, NN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

做法与上一题类似,在堆排序里判断就行了



#include<stdio.h>  
#include<stdlib.h>  
#include<algorithm>
#define MAX 101
using namespace std;  

void Swap(int *a,int *b)
{
	int t;
	t = *a;
	*a = *b;
	*b = t;
}

bool same(int A[],int change[],int N)
{
	for(int i = 0; i < N; i++)
	{
		if(A[i] != change[i])
		{
			return false;
		}
	}
	return true;
}

void print(int A[],int N)
{
	for(int i = 0; i < N; i++)
	{
		printf("%d",A[i]);
		if(i < N-1)
		printf(" ");
	}
}

bool Insert(int A[],int change[],int N)
{
	int i,Tmp,p;
	bool flag = false;
	for(i = 1; i < N; i++)
	{
		if(i != 1 && same(A,change,N) == true)/*原始序列不能作为比较*/
		{
			flag = true;
		}
		
		Tmp = A[i];
		for(p = i; p > 0 && A[p - 1] > Tmp; p--)
		{
			A[p] = A[p - 1];
		}
		A[p] = Tmp;
		
		if(flag == true)/*这时判断正确的话,说明数组在符合条件的情况下排出了下一步的序列,直接输出数组即可*/
		{
			break;
		}
		
	}
	if(flag == true)
	{
		printf("Insertion Sort\n");
		print(A,N);
		return true;
	}
	else
	{
		return false;
	}
}

void percDown(int A[],int p,int N)
{
	int parent,child,X;
	X = A[p];
	for(parent = p; (parent * 2) + 1 < N; parent = child)
	{
		child = parent * 2 + 1;
		if(child != N - 1 && A[child] < A[child + 1])
		{
			child++;
		}
		if(X >= A[child])break;
		else
		{
			A[parent] = A[child];
		}
	}
	A[parent] = X;
}

void heap(int A[],int N,int change[])
{
	int flag = false;
	for(int i = (N - 1)/2; i >=0; i--)
	{
		percDown(A,i,N);
	}
	
	for(int i = N - 1; i > 0; i--)
	{
		if(i != N - 1 && same(A,change,N))
		{
			flag = true;
		}
		
		Swap(&A[0],&A[i]);
		percDown(A,0,i);
		
		if(flag == true)
		{
			printf("Heap Sort\n");
			print(A,N);
			break;
		}
		
	}
}

int main(void)
{
	int N;
	scanf("%d",&N);
	int A[MAX];
	int change[MAX];
	int temp[MAX];/*temp用来备份,排序过程在temp数组里进行*/
	int flag = false;
	for(int i = 0; i < N; i++)
	{
		scanf("%d",&A[i]);
		temp[i] = A[i];
	}
	
	for(int i = 0; i < N; i++)
	{
		scanf("%d",&change[i]);
	}
	
	flag = Insert(temp,change,N);
	
	if(flag == false)
	{
		heap(A,N,change);
	}

	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值