HDU-1312-Red and Black

I - Red and Black
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1312
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

题意,.代表可通行#代表不可通行@代表起始点且可通行,输出一空可以到达多少个.

深度搜索用递归,不过那个输入地图大小的顺序真是坑啊,刚开始都没发现,样例输入居然是倒着输入地图大小

代码

#include<stdio.h>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<math.h>
#include<limits.h>
#include<iostream>
#include<algorithm>
using namespace std;
//深度搜索
char map[22][22];
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int m,n;//地图边界
int starx,stary;//起始点坐标
int num;//记录能到达的数量
void DFS(int starx,int stary)
{
    num++;
    map[starx][stary]='#';
    for(int i=0; i<4; i++)
    {
        int endx=starx+dir[i][0];
        int endy=stary+dir[i][1];
        if(endx>=0&&endx<m&&endy>=0&&endy<n&&map[endx][endy]=='.')//坐标合法且可通行
            DFS(endx,endy);
    }
    return;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(m==0&&n==0)
            break;
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='@')
                {
                    starx=i;
                    stary=j;
                }
            }
        }
        num=0;
        DFS(starx,stary);
        printf("%d\n",num);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值