HDU-3183-A Magic Lamp

E - A Magic Lamp HDU 3183
Time Limit: 1000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.
Sample Input
178543 4
1000001 1
100001 2
12345 2
54321 2
Sample Output
13
1
0
123
321

题意:给出一串数字,给出m,不改变原数字顺序的前提下,删掉m个数字,输出各种删除方法中,剩余数字最小的那一串剩余数字

贪心水题

#include<stdio.h>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<math.h>
#include<limits.h>
#include<iostream>
#include<algorithm>
using namespace std;
//贪心算法
char str[1010];
int a[1010];
int c[1010];
int main()
{
    int k,m,i,tt,len,j;
    while(~scanf("%s %d",str,&m))
    {
        len=strlen(str);
        for(i=0; i<len; i++)
            a[i]=str[i]-'0';//转化为int
        k=0;
        for(i=0; i<len-1&&m>0; i++)
        {
            if(a[i]<=a[i+1])//小的数存到c数组
            {
                c[k++]=a[i];
            }
            else
            {
                m--;
                while(c[k-1]>a[i+1]&&m>0)
                {
                    k--;//后退,覆盖之前的数
                    m--;//剩余删除数量
                }
            }
        }
        for(; i<len; i++)
            c[k++]=a[i];
        for(i=0; i<k-m; i++)
        {
            if(c[i]!=0)//除去前导零
                break;
        }
        if(i==k-m)//如果后面没数了
            printf("0");//输出零
        else
        {
            for(j=i; j<k-m; j++)
                printf("%d",c[j]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值