HDU-1003-Max Sum

A - Max Sum
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1003
Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

求最大子串和,和NYOJ-44题一样,只是这题还要输出区间
NYOJ-44http://blog.csdn.net/qq_32680617/article/details/50759863

思想都在注释里,不过这次代码写的不够简练,想的有点多。
注意空行输出的条件

#include<stdio.h>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<math.h>
#include<limits.h>
#include<iostream>
#include<algorithm>
using namespace std;
int this_i,this_j;//当前区间
int max_i,max_j;//最终区间
int this_sum;//当前最大值
int max_sum;//最终最大值
int temp;//临时接收数据
int T,N;//俩没用的数据
int main()
{
    cin>>T;
    int num=1;//计数的
    while(T--)
    {
        cin>>N;
        cin>>this_sum;//第一个数据作为初始值
        max_sum=this_sum;
        this_i=1,this_j=1,max_i=1,max_j=1;//初始化各值
        for(int i=2; i<=N; i++)
        {
            cin>>temp;//接收到一个数据
            if((this_sum+temp)<temp)
            {
                //如果当前最大值加上当前数据后小于当前数据
                this_sum=temp;//当前数据赋值给当前最大值
                this_i=i;//更改当前区间
                //this_j=i;
            }
            else
            {
                //如果当前最大值加上当前数据后大于等于当前数据
                this_sum+=temp;//当前最大值累加
               // this_j++;//当前区间终点+1
            }
            if(this_sum>max_sum)//如果当前最大值大于最终最大值
            {
                max_sum=this_sum;//更新最终最大值并更新最终区间
                max_i=this_i;
                max_j=i;
            }
        }
        printf("Case %d:\n",num++);
        printf("%d %d %d\n",max_sum,max_i,max_j);
        if(T!=0)
            printf("\n");
    }
    return 0;
}

动态规划的入门题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值