HDU-1171-Big Event in HDU

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32741 Accepted Submission(s): 11425

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 –value of facility) and an integer M (0<M<=100 –corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output
20 10
40 40

01背包问题,记录设备的总价值为sum,寻找接近sum/2的值即可,sum/2对应的值肯定小于等于真实的sum的一半。

状态转移方程:dp[j]=max(dp[j],dp[j-num[i]]+num[i]);
每次循环都比较获取最大值

代码

#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
//01背包
int num[5005];//50*100=5005
int dp[255555];//V<=50
int main()
{
    int n;//指令数据
    while(~scanf("%d",&n)&&n>0)
    {
        int length;//背包数组真实长度
        int sum;//价值总和
        memset(num,0,sizeof(num));
        memset(dp,0,sizeof(dp));
        length=0;
        sum=0;
        int v,m;//价值和数量
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&v,&m);
            while(m--)//m个v价值的设备
            {
                num[length++]=v;//获取总长度
                sum+=v;//获取总价值
            }
        }
       // length--;//这才是准确设备数量
        for(int i=0; i<length; i++)
        {
            for(int j=sum/2; j>=num[i]; j--)
            {
                dp[j]=max(dp[j],dp[j-num[i]]+num[i]);
            }
        }
        printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
    }
    return 0;
}

01背包问题比较具有代表性,可以写个专题总结一下

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值