HDU-1856-More is better(并查集 集合最值)

C - More is better
Time Limit:1000MS Memory Limit:102400KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1856
Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output
4
2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题意:有10000000个学生,多组输入,每组数据第一行给出T,代表T组数据,接下来T行,每行给出A,B,代表A和B在同一集合。找出元素最多的集合中的元素数量

思路:合并时注意路径压缩,否则会超时。num[i]记录以i为祖先的集合内元素数量,Father[]作为并查集数组

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
using namespace std;
//并查集
//查找所有集合中人数最多集合的人数
const int maxn=10000005;
int Father[maxn];//这个数组用来找爹
int num[maxn];//这个数组用来记录爹有多少个儿子
void init()
{
    for(int i=1; i<=maxn; i++)
    {
        Father[i]=i;
        num[i]=1;
    }
}
int Query(int x)//返回x的爹
{
    if(x!=Father[x])
        Father[x]=Query(Father[x]);//路径压缩
    return Father[x];//递归的过程顺便更改了递归过程中儿子的爹
}
void Merge(int x,int y)//y合并到x集合
{
    int flag_x=Query(x);
    int flag_y=Query(y);
    if(flag_x!=flag_y)
    {
        Father[flag_x]=flag_y;//x,y合并成一个爹
        num[flag_y]+=num[flag_x];//更新y所在集合最新儿子数量
    }
}
int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        if(T==0)
        {
            printf("1\n");
            continue;
        }
        init();
        int A,B;
        int right=0;//记录最右边的数
        for(int i=1; i<=T; i++)
        {
            scanf("%d%d",&A,&B);
            right=max(right,max(A,B));
            Merge(A,B);
        }
        int count=0;
        for(int i=1; i<=right; i++)
            count=max(count,num[i]);
        printf("%d\n",count);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值