POJ-1251-Jungle Roads(最小生成树 克鲁斯卡尔)

A - Jungle Roads
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 1251
Description

这里写图片描述
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30

图真的太小了,只有27,克鲁斯卡尔,普利姆都可以。
这里先给出克鲁斯卡尔的代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
//最小生成树
//克鲁斯卡尔算法
const int maxn=3333;//最多27个村庄
struct node
{
    int u;
    int v;
    int w;//u到v权值为w
} num[3333]; //不知道公有多少边
int Father[maxn];//并查集数组
int N;//村庄数目
void init()
{
    for(int i=1; i<=N; i++)
        Father[i]=i;
}
int Query(int x)
{
    if(x!=Father[x])
        Father[x]=Query(Father[x]);
    return Father[x];
}
int Merge(int x,int y)
{
    int flag_x=Query(x);
    int flag_y=Query(y);
    if(flag_x!=flag_y)
    {
        Father[flag_x]=flag_y;
        return 1;
    }
    return 0;
}
bool cmp(node x,node y)
{
    return x.w<y.w;
}
int main()
{
    while(~scanf("%d",&N)&&N)
    {
        int len=0;//边的数量
        for(int i=0;i<N-1;i++)//接收数据
        {
            char str1[2];
            int num_1;
            scanf("%s%d",str1,&num_1);
            for(int i=0;i<num_1;i++)
            {
                char str2[2];
                int num_2;
                scanf("%s%d",str2,&num_2);
                num[len].u=(int)(str1[0]-'A'+1);
                num[len].v=(int)(str2[0]-'A'+1);
                num[len++].w=num_2;
            }
        }
        sort(num,num+len,cmp);
        init();
        int min_dis=0;//最小权值
        int count=0;//生成树的边
        for(int i=0;i<len;i++)
        {
            if(Merge(num[i].u,num[i].v))
            {
                count++;
                min_dis+=num[i].w;
            }
            if(count==N-1)
            {
                printf("%d\n",min_dis);
                break;
            }
        }
    }
    return 0;
}

下面是普利姆的代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
//最小生成树
//普利姆算法
const int maxn=33;
const int INF=99999999;
int map[maxn][maxn];//邻接矩阵存图
int dis[maxn];
int vis[maxn];
int N;//N个村庄
void init()//初始化矩阵并存图
{
    for(int i=1; i<=N; i++)
        for(int j=1; j<=N; j++)
            i==j?map[i][j]=0:map[i][j]=INF;
    for(int i=0; i<N-1; i++)
    {
        char str1[2];
        int num_1;
        scanf("%s%d",str1,&num_1);
        for(int i=0; i<num_1; i++)
        {
            char str2[2];
            int num_2;
            scanf("%s%d",str2,&num_2);
            if(map[str1[0]-'A'+1][str2[0]-'A'+1]>num_2)
            {
                map[str1[0]-'A'+1][str2[0]-'A'+1]=num_2;
                map[str2[0]-'A'+1][str1[0]-'A'+1]=num_2;
            }
        }
    }
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    for(int i=1; i<=N; i++)
        dis[i]=map[i][1];
}
void Prim()
{
    int min_dis=0;//累计最小权值
    for(int i=1; i<N; i++)
    {
        int minn=INF;
        int point_minn;//记录松弛边的下标
        for(int j=1; j<=N; j++)
            if(vis[j]==0&&minn>dis[j])
            {
                minn=dis[j];
                point_minn=j;
            }
        if(minn==INF)
            break;
        vis[point_minn]=1;
        min_dis+=minn;
        for(int k=1; k<=N; k++)
            if(vis[k]==0&&dis[k]>map[point_minn][k])
                dis[k]=map[point_minn][k];
    }
    printf("%d\n",min_dis);
}
int main()
{
    while(~scanf("%d",&N)&&N)
    {
        init();
        Prim();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值