POJ-1122-FDNY to the Rescue!(迪杰斯特拉 反向建图 输出路径)

FDNY to the Rescue!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2952 Accepted: 908
Description

The Fire Department of New York (FDNY) has always been proud of their response time to fires in New York City, but they want to make their response time even better. To help them with their response time, they want to make sure that the dispatchers know the closest firehouse to any address in the city. You have been hired to write this software and are entrusted with maintaining the proud tradition of FDNY. Conceptually, the software will be given the address of the fire, the locations of the firehouses, street intersections, and the time it takes to cover the distance between each intersection. It will then use this information to calculate how long it takes to reach an address from each firehouse.
这里写图片描述
Given a specific fire location in the city, the software will calculate the time taken from all the fire stations located in the city to reach the fire location. The list of fire stations will be sorted from shortest time to longest time. The dispatcher can then pick the closest firestation with available firefighters and equipment to dispatch to the fire.
Input

Line 1:
# of intersections in the city, a single integer (henceforth referred to as N) N<20

Lines 2 to N+1:
A table (square matrix of integer values separated by one or more spaces) representing the time taken in minutes between every pair of intersections in the city. In the sample input shown below the value “3” on the 1st row and the 2nd column represents the time taken from intersection #1 to reach intersection #2.

Similarly the value “9” on the 4th row and the 2nd column represents the time taken from intersection #4 to reach intersection #2.

A value of -1 for time means that it is not possible to go directly from the origin intersection (row #) to the destination intersection (column #). All other values in the table are non-negative.

Line N+2:
An integer value n (<= N) indicating the intersection closest to the fire location followed by one or more integer values for the intersections closest to the fire stations (all on one line, separated by one or more spaces) will follow the input matrix.

Notes on input format:

  1. The rows and columns are numbered from 1 to N.
  2. All input values are integers
  3. All fire locations are guaranteed reachable from all firehouses.
  4. All distance calculations are made from the intersection closest to each firehouse to the intersection closest to the fire.
    Output

Line 1:
A label line with the headings for each column, exactly as shown in the example.

Line 2 onwards (one line for each fire station):
A sorted list (based on time) showing the fire station (origin), the destination site, time taken and a complete shortest path of nodes from the originating fire station to the fire location.

Notes on output format:
1. Columns are tab separated.
2. If two or more firehouses are tied in time they can be printed in any order.
3. If more than one path exists that has the same minimal time for a given location & firehouse, either one can be printed on the output.
4. If the fire location and the fire station locations happen to be the same intersection, the output will indicate that the origin and destination have the same intersection number, the time will be “0” and the nodes in the shortest path will show just one number, the fire location.
Next is the picture for the sample input data.

Sample Input

6
0 3 4 -1 -1 -1
-1 0 4 5 -1 -1
2 3 0 -1 -1 2
8 9 5 0 1 -1
7 2 1 -1 0 -1
5 -1 4 5 4 0
2 4 5 6
In the above input the last line indicates that “2” is the location of the fire and “4”, “5” and “6” are the intersections where fire stations are located.
Sample Output

Org Dest Time Path
5 2 2 5 2
4 2 3 4 5 2
6 2 6 6 5 2

题意:给张图,最后一行给一行数,第一个数代表起点,后面的是终点,按照时间排序输出路径。

思路:多点到某点,反向建图套用单源最短路,松弛各边是可以实时记录路径。

代码

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=22;
const int INF=0x3f3f3f3f;
int map[maxn][maxn];
int dis[maxn];
bool vis[maxn];
int path[maxn];
struct node
{
    int point;
    int step;
} num[maxn];
int len_num;
int N;
bool cmp(node x,node y)
{
    return x.step<y.step;
}
void Dijkstra(int star)
{
    for(int i=1; i<=N; i++)
    {
        dis[i]=map[star][i];
        vis[i]=0;
        if(i!=star&&dis[i]<INF)
            path[i]=star;
        else
            path[i]=-1;

    }
    vis[star]=1;
    for(int i=0; i<N-1; i++)
    {

        int minn=INF;
        int point;
        for(int j=1; j<=N; j++)
        {
//            printf("****\n");
//            printf("%d  %d  %d\n",vis[j],minn,dis[j]);
            if(vis[j]==0&&dis[j]<minn)
            {

                minn=dis[j];
                point=j;
            }
        }

        vis[point]=1;
        for(int j=1; j<=N; j++)
            if(vis[j]==0&&map[point][j]!=INF&&dis[j]>dis[point]+map[point][j])
            {
                dis[j]=dis[point]+map[point][j];
                path[j]=point;
            }
    }
}
int main()
{
    scanf("%d",&N);
    for(int j=1; j<=N; j++)
        for(int i=1; i<=N; i++)
        {
            scanf("%d",&map[i][j]);//反向制图
            if(map[i][j]==-1)
                map[i][j]=INF;
        }
    int star;
    scanf("%d",&star);
    Dijkstra(star);
    len_num=0;
    int flag;
    while(cin>>flag)
    {
        num[len_num].point=flag;
        num[len_num].step=dis[flag];
        len_num++;
    }
    sort(num,num+len_num,cmp);
    printf("Org\tDest\tTime\tPath\n");
    for(int i=0; i<len_num; i++)
    {
        printf("%d\t%d\t%d\t",num[i].point,star,num[i].step);
        int j=0;
        int shortest[maxn];//记录单条路径
        shortest[j]=num[i].point;//手动添加终点
//        printf("%d\n",path[star]);
        while(path[shortest[j]]!=-1)
        {
            j++;
            shortest[j]=path[shortest[j-1]];
        }
//        j++;
//        shortest[j]=star;
        for(int k=0;k<=j;k++)
            printf("%d\t",shortest[k]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值