HDU-2844-Coins(多重背包 二进制优化)

Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12753 Accepted Submission(s): 5120

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4

题意:多组数据,每组数据第一行给出N和V代表接着有N行,每行两个数字ai和ci,代表有ci个价值为ai的硬币,这些硬币组合出任意1~V的价值有多少种组合方法。

思路:多重背包加二进制转换优化

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
//多重背包 二进制优化
const int maxn=100005;
int Ai[maxn];//价值
int Ci[maxn];//数量
int DP[maxn];//剩余容量为i时获取的最大价值为DP[i]
int N;//物品数量
int V;//背包容量
int main()
{
    while(scanf("%d%d",&N,&V)&&N&&V)
    {
        for(int i=1; i<=N; i++)
            scanf("%d",&Ai[i]);
        for(int i=1; i<=N; i++)
            scanf("%d",&Ci[i]);
        for(int i=0; i<=V; i++)
            DP[i]=0;//初始化背包
        for(int i=1; i<=N; i++)//多重背包
        {
            if(Ai[i]*Ci[i]>=V)//完全背包
                for(int v=Ai[i]; v<=V; v++)
                    DP[v]=max(DP[v],DP[v-Ai[i]]+Ai[i]);
            else//背包 二进制优化
            {
                int flag=Ci[i];
                for(int k=1; k<=flag; flag-=k,k=k*2)
                    for(int v=V; v>=Ai[i]*k; v--)
                        DP[v]=max(DP[v],DP[v-Ai[i]*k]+Ai[i]*k);
                for(int v=V; v>=Ai[i]*flag; v--)
                    DP[v]=max(DP[v],DP[v-Ai[i]*flag]+Ai[i]*flag);
            }
        }
        int result=0;
        for(int i=1; i<=V; i++)
            if(DP[i]==i)//硬币价值总和为i
                result++;
        printf("%d\n",result);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值