Subtraction (20分)
Given two strings S
1
and S
2
, S=S
1
−S
2
is defined to be the remaining string after taking all the characters in S
2
from S
1
. Your task is simply to calculate S
1
−S
2
for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S
1
and S
2
, respectively. The string lengths of both strings are no more than 10
4
. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S
1
−S
2
in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
就是一个去重的过程,很简单
#include <iostream>
#include <algorithm>
using namespace std;
#include <list>
int main()
{
list<char> listt;
string s1,s2;
getline(cin,s1);
getline(cin,s2);
int sign[9999]={0};
for(int i=0;i<s2.size();i++){
sign[s2[i]]=1;
}
for(int i=0;i<s1.size();i++){
if(sign[s1[i]]==0)
listt.push_back(s1[i]);
}
for(auto it=listt.begin();it!=listt.end();it++){
cout<<*it;
}
return 0;
}