hdu2057 A + B Again

A + B Again

 

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25617    Accepted Submission(s): 10406

 

 

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

 

 

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

 

 

Output

For each test case,print the sum of A and B in hexadecimal in one line.

 

 

Sample Input

 

+A -A +1A 12 1A -9 -1A -12 1A -AA

 

 

Sample Output

 

0 2C 11 -2C -90

 

 

这道题本来是一次过的,思路完全正确,但是在输出格式那里,我本来是

                if(a+b<0)printf("-%llx\n",-(a+b));
		else printf("%llx\n",a+b);

按十六进制输出,我这里用的是小写‘x’,但是就是ac不了,改成大写的‘X’就可以了,搞不懂

 

#include<cstdio>
int main()
{
	long long a,b;
	while(scanf("%llX %llX",&a,&b)!=EOF)
	{	
		if(a+b<0)printf("-%llX\n",-(a+b));
		else printf("%llX\n",a+b);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值