hdu1241 Oil Deposits _DFS

 

Oil Deposits

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28580    Accepted Submission(s): 16504

 

 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

 

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

 

 

Sample Output

 

0 1 2 2

 

 

 

 

DFS连通块个数,从任意的 @ 开始,不停地把邻接的部分用'*'代替。
1次DFS后与初始的这个@连接的所有@就都被替换成了'*',因此直到图中不再存在@为止,
总共进行DFS的次数就是答案了。

 

//
// Created by Admin on 2017/3/2.
//
#include <cstdio>
#include <iostream>
using namespace std;

int m,n;
char grid[110][110];  //网格坐标

void dfs(int x,int y){  //现在位置(x,y) 
    grid[x][y]='*';  //将现在所在位置替换为'*'
    for(int dx=-1;dx<=1;dx++)  //循环遍历移动的八个方向
        for(int dy=-1;dy<=1;dy++){
            int nx=x+dx,ny=y+dy;   //x方向移动dx,y方向移动dy,结果为(nx,ny);
             //判断(nx,ny)是否在网格内,以及是否有oil pocket'@' 
            if(0<=nx && nx<m && 0<=ny && ny<n && grid[nx][ny]=='@')
                dfs(nx,ny);
        }
    return;
}

int main(){
    while(cin>>m>>n){
        if(m==0||n==0)break;
        for(int i=0;i<m;i++)
            scanf("%s",grid[i]);
        int ans=0;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(grid[i][j]=='@'){  //从有'@'(oil pocket)的地方开始DFS 
                    dfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值