hdu1016 Prime Ring Problem _DFS

 

Prime Ring Problem

 

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47494    Accepted Submission(s): 20997

 

 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

 

Sample Input

 

6 8

 

 

Sample Output

 

Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

题意: 输出满足相邻两数之和为素数的环序列 
DFS遍历所有情况 

 

 

#include<iostream>
#include<cstdio>
#include<cmath> 
using namespace std;

int n,s[25],mark[25]; 

bool IS_prime(int a){  //素数判断 
	bool flag=true;
	for(int i=2;i<=sqrt(a);i++){
		if(a%i==0){
			flag=false;
			break;
		}
	}
	return flag;
}

void dfs(int pos){  //pos代表当前搜索深度 
	if(pos==n && IS_prime(s[n]+1) ){
		for(int i=1;i<n;i++)printf("%d ",s[i]);
		printf("%d",s[n]);
		printf("\n");
	}
	for(int i=2;i<=n;i++)
	   if(mark[i]!=0 && IS_prime(s[pos]+i)){
	   	s[pos+1]=i;
	   	mark[i]=0;  //标记数字"i"已使用 
	   	dfs(pos+1);
	   	mark[i]=i;  //回溯时,恢复原状态,标志数字"i"未使用 
	   }
}

int main(){
	int count=0;
	s[1]=1;
	for(int i=1;i<20;i++)
	    mark[i]=i;  //搜索时,mark数组用于记录数字是否用过 
	while(cin>>n){
		printf("Case %d:\n",++count);
		dfs(1);
		printf("\n");
	}
	return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值