Longest Ordered Subsequence

Problem describe:

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence ( a1, a2, …, aN) be any sequence ( ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意分析:

这道题的意思就是让你求在给定的一个序列中的一个有序数列的最大长度
解题思路:

一个有序的数列要么是递增的,要么是递减的,为了方便我就找递增的,从这个序列的第二个数开始,如果他比他前面的数大,并且前i-1项的最大增长度要比当前位置的最大增序列长度要小,这样做就可以在一个序列中找出有序数列最长的长度,自己可以代入一些数据去模拟一遍,自然就懂了。
程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[20000],len[20000];
int main()
{
	int i,j,k,n,tempmax,ma;
	while(scanf("%d",&n)!=EOF)
	{
		memset(len,0,sizeof(len));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		len[1]=1;//以a[1]为终点最长增序列的长度
		for(i=2;i<=n;i++)
		{
			tempmax=0;
			for(k=1;k<i;k++)
			{
				if(a[k]<a[i]&&tempmax<len[k])
				tempmax=len[k];
			}
			len[i]=tempmax+1;//以a[i]为终点的最长增序列的长度
		}
		ma=len[1];//找出len中的最大值即可
		for(i=2;i<=n;i++)
			ma=max(ma,len[i]);
		printf("%d\n",ma);		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值