POJ 3013 Big Christmas Tree

Big Christmas Tree
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 23525 Accepted: 5104
Description

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers v, e (0 ≤ v, e ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers a, b, c indicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9
Sample Output

15
1210
题意:给你一个计算权值的公式,然后计算一条最短路的权值
直接建立邻接表,正反处理点,然后直接模板spfa,统计权值就行了

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
const int VM=50010;
const int EM=50010;
const long long INF=9999999999;
#define LL long long
using namespace std;
int n,m,k,wight[VM];
int head[VM],vist[VM];
long long d[VM];

struct node{
    int v,next;
    long long w;
}map[EM<<1];

void addmap(int u,int v,long long w)
{
    map[k].v=v;
    map[k].w=w;
    map[k].next=head[u];
    head[u]=k++;
}
LL spfa()
{
    int i;
    queue<int>q;
    while(!q.empty())
        q.pop();
    for(i=1; i<=n; i++)
    {
        d[i]=INF;
        vist[i]=0;
    }
    d[1]=0;
    vist[1]=1;
    q.push(1);
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        vist[now]=0;
        for(i=head[now]; i!=-1; i=map[i].next)
        {
            int v=map[i].v;
            if(d[v]>d[now]+map[i].w)
            {
                d[v]=d[now]+map[i].w;
                if(!vist[v])
                {
                    vist[v]=1;
                    q.push(v);
                }
            }
        }
    }
    LL ans=0;
    for(i=1; i<=n; i++)
    {
        if(d[i]==INF)
            return 0;
        ans+=wight[i]*d[i];
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        k=0;
        memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            scanf("%d",&wight[i]);
        int u,v;
        LL w;
        while(m--)
        {
            scanf("%d%d%I64d",&u,&v,&w);
            addmap(u,v,w);
            addmap(v,u,w);
        }
        if(n==0 || n==1)
        {
            printf("0\n");
            continue;
        }
        long long ans=spfa();
        if(ans==0)
            printf("No Answer\n");
        else
            printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值