hdu1394Minimum Inversion Number

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
10
1 3 6 9 0 8 5 7 4 2

Sample Output
16
求最小逆序数的数列,逆序数的意思是比如:
2 5 3 4 1
每个数计算它后面有多少,然后计算总和,即
2 5 3 4 1 原数列
1 3 1 1 每个数的逆序1+3+1+1=6

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

struct Tree
{
    int l,r,mid;
    int sum;
}T[15555];

void build(int l,int r,int k)
{
    T[k].l = l;
    T[k].r = r;
    T[k].mid = (l+r) >> 1;
    T[k].sum = 0;
    if (l == r)
    return ;
    build(l,T[k].mid,k << 1);
    build(T[k].mid+1,r,k<<1|1);
}

void insert(int num,int l,int r,int k)
{
    if(T[k].l == num && T[k].r == num)
    {
        T[k].sum++;
        return;
    }
    if(num <= T[k].mid)
    insert(num,l,T[k].mid,k<<1);
    else
    insert(num,T[k].mid+1,r,k<<1|1);
    T[k].sum = T[k<<1].sum + T[k<<1|1].sum;
}

int ans;
void search(int l,int r,int k)
{
    if(T[k].l == l && T[k].r == r)
    {
        ans+=T[k].sum;
        return ;
    }
    if(r <= T[k].mid)
    search(l,r,k<<1);
    else if(l > T[k].mid)
    search(l,r,k<<1|1);
    else
    {
        search(l,T[k].mid,k<<1);
        search(T[k].mid+1,r,k<<1|1);
    }
}

int main()
{
    int n,i,num[5005],sum,text;
    while(cin >> n)
    {
        build(1,n,1);
        sum = 0;
        for(i = 0;i<n;i++)
        {
            cin >> num[i];
            num[i]++;
            ans = 0;
            if(num[i]!=n)
            search(num[i]+1,n,1);
            sum += ans;
            insert(num[i],1,num[i],1);
        }
        text = sum;
        for(i = n-1;i>=0;i--)
        {
            sum = sum - (n-num[i])+(num[i]-1);
            text = min(text,sum);
        }
        cout << text << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值