hdu1054Strategic Game

Strategic Game
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7770 Accepted Submission(s): 3709

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output
1
2
守卫一座城市,每个节点连接一些边,一个士兵可以守卫一条街,问最少放多少士兵能保证城市安全
就是变相的最小定点覆盖=最大匹配()/2
用邻接表建图,分出两个初始图,然后从1图u点开始像图2任意未匹配节点发出一条边连接,然后寻找一条最短的增广路。
邻接表用STL容器建立。

#include <cstdio>
#include <vector>//用STL容器来建立邻接表
#include <cstring>
#include <algorithm>
#define N 1510
using namespace std;
int link[N],vist[N];
int VN;
vector<int>mp[N];
bool dfs(int u)
{
    for(int i=0; i<mp[u].size(); i++)
    {
        if(!vist[mp[u][i]])
        {
            vist[mp[u][i]]=1;
            if(link[mp[u][i]]==-1||dfs(link[mp[u][i]]))
            {
                link[mp[u][i]]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary()
{
    int cnt=0;
    memset(link,-1,sizeof(link));
    for(int i=0; i<VN; i++)
    {
        memset(vist,0,sizeof(vist));
        if(dfs(i))
            cnt++;
    }
    return cnt;
}
int main()
{
    int u,k,v,n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<N; i++)
            mp[i].clear();
        for(int i=0;i<n;i++)//while在这不能使用
        {
            scanf("%d:(%d)",&u,&k);
            while(k--)
            {
                scanf("%d",&v);
                mp[u].push_back(v);
                mp[v].push_back(u);
            }
        }
        VN=n;
        printf("%d\n",hungary()/2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值