hdu1054(二分图+最小点覆盖数+匈牙利算法)

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3735    Accepted Submission(s): 1644


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2
 
 
题目要求最少要多少个人就可以守住所有路口,即最小点覆盖数,有二分图的理论:最小点覆盖数=最大匹配数
 
#include<iostream>
#include<string>
#include<vector>
#include<cstdio>
using namespace std;


const int MAXN=1500;
int uN,vN;//u,v数目
//int g[MAXN][MAXN];
vector<int>g[MAXN];
int linker[MAXN];
bool visited[MAXN];
inline bool dfs(int u)//从左边开始找增广路径
{
    int v;
    for(v=0;v<g[u].size();v++)//这个顶点编号从0开始,若要从1开始需要修改
	{
		int tmp=g[u][v];
		if(!visited[tmp])
		{
          visited[tmp]=true;
          if(linker[tmp]==-1||dfs(linker[tmp]))
          {//找增广路,反向
              linker[tmp]=u;
              return true;
          }
      }
	}
    return false;//这个不要忘了,经常忘记这句
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++)
    {
        memset(visited,0,sizeof(visited));
        if(dfs(u)) res++;
    }
    return res;
}
//****************************************************
int main()
{
	int i,j,n,s,e;
	while(~scanf("%d",&uN))
	{
		vN=uN;
		for(i=0;i<uN;i++)
			g[i].clear();
		memset(g,0,sizeof(g));
		for(i=0;i<uN;i++)
		{
			scanf("%d:(%d)",&s,&n);
			for(j=0;j<n;j++)
			{
				scanf("%d",&e);
				g[s].push_back(e);
				g[e].push_back(s);
			}
		}

		printf("%d\n",hungary()/2);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值