hdu1081 To the Max

To the Max

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 1 Accepted Submission(s) : 1
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2

Sample Output
15

求最大矩阵和

做dp[i][j]表示前i行前j列最大值
则有dp[i][j]=max(dp[i][j],dp[i][j-1]+a[i][j])

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#define INF 0xffff
using namespace std;

int main()
{
    int n;
    int a[150][150];
    int dp[150][150];///dp[i][j]表示在i行时前j列的最大值
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                {
                    scanf("%d",&a[i][j]);
                    dp[i][j]+=dp[i][j-1]+a[i][j];
                }
        //dp[0][0]=a[0][0];
        int maxn=-100000;
        for(int i=1;i<=n;i++)
        {
            //dp[i][0]=max(dp[i][0],dp[i-1][0]+a[i][j]);
            for(int j=i;j<=n;j++)
            {
                int sum=0;
                for(int k=1;k<=n;k++)
                {
                    if(sum<0)
                    sum=0;
                    sum+=dp[k][j]-dp[k][i-1];
                    if(sum>maxn)
                    maxn=sum;
                }
                //dp[i][j]=max(dp[i][j],dp[i-1][j]+dp[i][j-1]+a[i-1][j]+a[i][j-1]);
            }
        }
        cout<<maxn<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值