poj 2955 Brackets(括号匹配)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7695 Accepted: 4079
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6

题意:给字符串。输出当前字符串有多少个匹配的字符

思路:dp[i][j]为从i字符到j字符的最大匹配数
枚举所有的距离,从下图中 ① 到 ⑤ 枚举最大的值输出
f(i 3~n)
f(j 0~i+j-1 )
f(k i~j-1)
地推方程:
dp[i][j]=dp[i][j],dp[i][k]+dp[k+1][j];

这里写图片描述

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
char str[110];
int dp[110][110];
int match(int i,int j)
{
    if(str[i]=='('&&str[j]==')')
        return 1;
    if(str[i]=='['&&str[j]==']')
        return 1;
    return 0;
}
int main()
{
    int n,c;
    while(scanf("%s",str)>0&&str[0]!='e')
    {
        //getchar();
        n=strlen(str);
        //cout<<n<<endl;
        //memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            dp[i][i]=0;
            if(match(i,i+1))
                dp[i][i+1]=2;
            else
                dp[i][i+1]=0;
        }

        for(int j=3; j<=n; j++)
        {
            for(int i=0; i+j-1<n; i++)
            {
                dp[i][i+j-1]=0;
                if(match(i,i+j-1))
                    dp[i][i+j-1]=dp[i+1][i+j-2]+2;
                for(int k=i; k<i+j-1; k++)
                {
                    dp[i][i+j-1]=max(dp[i][i+j-1],dp[i][k]+dp[k+1][i+j-1]);
                }
            }
        }
        cout<<dp[0][n-1]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值