hdu6090Rikka with Graph(规律)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 672 Accepted Submission(s): 394

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G (wG) as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(i≠j) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).

Input
The first line contains a number t(1≤t≤10), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤106,1≤m≤1012).

Output
For each testcase, print a single line with a single number – the answer.

Sample Input
1
4 5

Sample Output
14

求出无向图n个点,m条边时 ∑ni=1∑nj=1dist(i,j).的值为多少。

/*
三种情况:
1.当m远远大于n*(n-1)/2时,则边已经能够让每两个点之间连线了,即权值为n*(n-1),

 2.当2*(n-1)/2>m>=n-1时,先让n-1条边将点连成放射状。这样点点之间距离为2
 ,剩下的m-n+1个点让(m-n+1)*2个点距离缩短1,

3.当m<n-1时,让m+1个点连成一个放射块,剩下n-m-1个点则为孤独点,分别计算。
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
int main()
{
    long long t;
    scanf("%d",&t);
    long long n,m;
    while(t--)
    {
        scanf("%lld %lld",&n,&m);
        long long mos=n*(n-1)/2;
        long long sum;
        if(m>=mos)
        {
            sum=(long long)(n*(n-1));
        }
        else if(m<n-1)
        {
            sum=(long long)(2*m*m+n*(n+m)*(n-m-1));
        }
        else
        {
            sum=(long long)((n-1)*(n-1)*2-2*(m-n+1));
        }
        cout<<sum<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值