hdu6143Killer Names(第八场容斥组合数)

Killer Names

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1187    Accepted Submission(s): 581


Problem Description
> Galen Marek, codenamed Starkiller, was a male Human apprentice of the Sith Lord Darth Vader. A powerful Force-user who lived during the era of the Galactic Empire, Marek originated from the Wookiee home planet of Kashyyyk as the sole offspring of two Jedi Knights—Mallie and Kento Marek—who deserted the Jedi Order during the Clone Wars. Following the death of his mother, the young Marek's father was killed in battle by Darth Vader. Though only a child, Marek possessed an exceptionally strong connection to the Force that the Dark Lord of the Sith sought to exploit.
>
> When Marek died in 2 BBY, shortly after the formation of the Alliance, Vader endeavored to recreate his disciple by utilizing the cloning technologies of the planet Kamino. The accelerated cloning process—an enhanced version of the Kaminoan method which allowed for a rapid growth rate within its subjects—was initially imperfect and many clones were too unstable to take Marek's place as the Dark Lord's new apprentice. After months of failure, one particular clone impressed Vader enough for him to hope that this version might become the first success. But as with the others, he inherited Marek's power and skills at the cost of receiving his emotions as well, a side effect of memory flashes used in the training process.
>
> — Wookieepedia

Darth Vader is finally able to stably clone the most powerful soilder in the galaxy: the Starkiller. It is the time of the final strike to destroy the Jedi remnants hidden in every corner of the galaxy.

However, as the clone army is growing, giving them names becomes a trouble. A clone of Starkiller will be given a two-word name, a first name and a last name. Both the first name and the last name have exactly  n  characters, while each character is chosen from an alphabet of size  m . It appears that there are  m2n  possible names to be used.

Though the clone process succeeded, the moods of Starkiller clones seem not quite stable. Once an unsatisfactory name is given, a clone will become unstable and will try to fight against his own master. A name is safe if and only if no character appears in both the first name and the last name.

Since no two clones can share a name, Darth Vader would like to know the maximum number of clones he is able to create.
 

Input
The First line of the input contains an integer  T  ( T10 ), denoting the number of test cases. 

Each test case contains two integers  n  and  m  ( 1n,m2000 ).
 

Output
For each test case, output one line containing the maximum number of clones Vader can create.

Output the answer   mod 109+7
 

Sample Input
  
  
2 3 2 2 3
 

Sample Output
  
  
2 18
 

Source

题意:m种字符放在两个长度为n的名,字中,问让两边颜色不同有多少种存放方式,假设前n个名为i种字符,那么后面的n字则有字符m-i种,这样就变成了容斥问题: 如果n个长度用x个字符表达,那就相当于n个不同小球放在x个不同的盒子里。设其结果为f(x),那么f(x) = x ^ n - C(x, 1) * f(x - 1) - C(x, 2) * f(x - 2) …… - C(x, x - 1) * f(1). 然后就是枚举所有的x,统计其和

#include<cstdio>
#define mod 1000000007
#include<iostream>
using namespace std;

typedef long long LL;
LL C[2005][2005];
LL cal[2005];
LL n,m;

LL quickM(LL a, LL b)
{
    LL ans = 1;
    while(b)
    {
        if(b & 1) ans = ans * a % mod;
        b >>= 1;
        a = a * a % mod;
    }
    return ans;
}
void init()
{
    C[0][0] = 1;
    for(int i = 1; i <= 2001; i++)///这里只算到2001,到2005超时。。无法理解
    {
        C[i][0] = 1;
        for(int j = 1; j <= i; j++)
        {
            C[i][j] = (C[i - 1][j] + C[i - 1][j - 1]) % mod;
        }
    }
}
void calt()///算出i^n-∑C(i,j)*j^n,也就是i个字符存在n个名字中的存放方式
{
    for(LL i = 1; i <= n; i++)
        {
            cal[i] =  quickM(i, n);
            for(int j = 1; j < i; j++)
            {
                cal[i] -= C[i][j] * cal[j] % mod;
                cal[i] = (cal[i] + mod ) % mod;

            }
        }

}
int main()
{
    init();
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%lld%lld", &n, &m);
        LL ans = 0;
        calt();
        //cout<<"cal-->"<<cal[5]<<endl;
        for(LL i = 1; i <= n; i++)
        {
            if(i >= m) break;
            for(LL j = 1; j <= n; j++)
            {
                if(j > m - i) break;
                ans += C[m][i] * cal[i] % mod * cal[j] % mod * C[m - i][j] % mod;///名和字分别乘起来,统计总数
                //cout<<"ans-->"<<C[m][i]<<C[m-i][j]<<endl;
                ans %= mod;
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值