Switch Game

   There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
Sample Input
1
5
Sample Output
1

0

----------------------------我是滑稽的分割线------------------------------------------------------------------------

思路分析:

每个人进入都会改变灯的状态,第n个进入就会改变n的倍数的号的灯,比如第一个进所有数字都被改变,第二个进,2、4、6、8....状态会反转。

实质上就是求:一个数字的因子个数。

回顾总结:

该题暂未遇到坑。

#include <iostream>
#include<string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int lamp[100001];
//求能被这个数整除的个数 
int main(int argc, char** argv) {
int n;
while(cin>>n)
{
	int ct=0;
	for(int i=1;i<=n;i++)
	{
		if(n%i==0)
		ct++;
	 } 
	 if(ct%2==0)
	 {
	 printf("0\n");
	 }
	 else
	 {
	  printf("1\n");
	 }
}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值