哈理工OJ 1029 Function Run Fun(记忆思想)

Function Run Fun
Time Limit: 1000 MS Memory Limit: 65536 K
Total Submit: 339(159 users) Total Accepted: 168(146 users) Rating: Special Judge: No
Description
We all love recursion! Don’t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.

Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

题目本身并不是太难,就是简单的递推,但难的地方就是你不知道把已经知道的结果储存起来,所以呢。在这个题中,我学会课记忆的思想,假如你已经算出了某个式子的结果,那么把他的结果储存在一个静态的数组里,下次再出现相同的问题的时候,直接返回答案就好了,省去了很多时间。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;

LL mem[21][21][21]={0};
LL fun(LL a,LL b,LL c)
{
    if(a<=0||b<=0||c<=0)
    {
        return 1;
    }
    if(a>20||b>20||c>20)
    {
        return 1048576;
    }
    if(mem[a][b][c])
    {
        return mem[a][b][c];
    }
    if(a<b&&b<c)
    {
        return mem[a][b][c]=fun(a,b,c-1)+fun(a,b-1,c-1)-fun(a,b-1,c);
    }
    else
    {
        return mem[a][b][c]=fun(a-1,b,c)+fun(a-1,b-1,c)+fun(a-1,b,c-1)-fun(a-1,b-1,c-1);
    }
}

int main()
{
    LL a,b,c;
    while(~scanf("%lld%lld%lld",&a,&b,&c))
    {
        if(a==-1&&b==-1&&c==-1)
        {
            break;
        }
        LL re=fun(a,b,c);

        printf("w(%lld, %lld, %lld) = %lld\n",a,b,c,re);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值