HDU 3342 Legal or Not(拓扑排序)

36 篇文章 0 订阅
6 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=3342
Legal or Not

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7156 Accepted Submission(s): 3406

Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.

Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output
YES
NO

Author
QiuQiu@NJFU

Source
HDOJ Monthly Contest – 2010.03.06

题目的意思是:问能不能构成拓扑排序,能构成的话,就输出YES,否则的话就输出NO。
下面是AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int MAXN=200;
int n,m,map[MAXN][MAXN];
int c[MAXN];
int topo[MAXN],t;


bool dfs(int u)
{
   c[u]=-1;//访问标志
   for(int v=0;v<n;v++)
   {
      if(map[u][v])
      {
         if(c[v]<0)//判断是否为有向环
         {
            return false ;
         }
         else if (!c[v])
         {
              if(!dfs(v))
              {
                  return false;
              }
         }
       }
    }
    c[u] = 1 ;
    topo[--t] = u ;//至于这里为什么这样子写,大家可以思考一下,这里是其中一组拓扑顺序,可有可无
    return true ;
}


bool toposort()
{
    t=n;
    memset(c,0,sizeof(c));
    for(int i=0;i<n;i++)
    {
       if(!c[i])
       {
           if(!dfs(i))
           {
            return false ;
           }
       }
     }
    return true ;
}


int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        memset(map,0,sizeof(map));
        memset(topo,0,sizeof(topo));
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            map[u][v]=1;
        }
        bool re=toposort();
        if(re)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值