2016 ACM/ICPC Asia Regional Dalian Online Sparse Graph(BFS)

61 篇文章 0 订阅
36 篇文章 0 订阅

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=5876

Sparse Graph

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 122 Accepted Submission(s): 46

Problem Description
In graph theory, the complement of a graph G is a graph H on the same vertices such that two distinct vertices of H are adjacent if and only if they are not adjacent in G.

Now you are given an undirected graph G of N nodes and M bidirectional edges of unit length. Consider the complement of G, i.e., H. For a given vertex S on H, you are required to compute the shortest distances from S to all N−1 other vertices.

Input
There are multiple test cases. The first line of input is an integer T(1≤T<35) denoting the number of test cases. For each test case, the first line contains two integers N(2≤N≤200000) and M(0≤M≤20000). The following M lines each contains two distinct integers u,v(1≤u,v≤N) denoting an edge. And S (1≤S≤N) is given on the last line.

Output
For each of T test cases, print a single line consisting of N−1 space separated integers, denoting shortest distances of the remaining N−1 vertices from S (if a vertex cannot be reached from S, output “-1” (without quotes) instead) in ascending order of vertex number.

Sample Input
1
2 0
1

Sample Output
1

Source
2016 ACM/ICPC Asia Regional Dalian Online

【分析】给出原图,找出原图的补图,求其中某个点到其他点的距离。
用map来存边,查找起来可以更方便。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<map>
#include<queue>
using namespace std;
map<int,int>e[200005];

int re[200005],book[200005];
int ss[200005];
int n,m;
void bfs(int s)
{
    memset(re,-1,sizeof(re));
    memset(book,0,sizeof(book));
    book[s]=1;
    queue<int>q;
    int sum=1;//记录已走点的总数,剪枝用
    for(int i=1; i<=n; i++)
    {
        if(!e[s].count(i)&&i!=s)//如果原图中没有并且不是s
        {
            sum++;
            q.push(i);
            re[i]=1;
            book[i]=1;
        }
    }
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        for(int i=1; i<=n; i++)
        {
            if(book[i]==0)//还没有被访问过
            {
                if(!e[x].count(i))//原图中没有
                {
                    sum++;
                    book[i]=1;
                    q.push(i);
                    re[i]=re[x]+1;
                }
            }
            if(sum==n)//找完了所有的点,剪枝
            {
                break;
            }
        }
        if(sum==n)
        {
            break;
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int cc,v;
        scanf("%d%d",&n,&m);
        memset(ss,0,sizeof(ss));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&cc,&v);
            ss[cc]++;
            ss[v]++;
            if(!e[cc].count(v))
            {
                e[cc][v]=1;
            }
            if(!e[v].count(cc))
            {
                e[v][cc]=1;
            }
        }
        int s;
        scanf("%d",&s);
        bfs(s);
        int flag=0;
        for(int i=1; i<=n; i++)
        {
            if(i==s)
            {
                continue;
            }
            if(flag==0)
            {
                printf("%d",re[i]);
                flag=1;
                continue;
            }
            printf(" %d",re[i]);
        }
        printf("\n");
        for(int i=1; i<=n; i++)//处理map
            e[i].clear();
    }
    return 0;
}
  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值