POJ 2407 Relatives(欧拉函数的应用)

25 篇文章 0 订阅

题目链接:
http://poj.org/problem?id=2407

Relatives
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13726 Accepted: 6854
Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output

For each test case there should be single line of output answering the question posed above.
Sample Input

7
12
0
Sample Output

6
4
Source

Waterloo local 2002.07.01

本题是一道简单的欧拉函数的题目,要求的为phi(n)的值。直接最暴力的方法。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int phi(int n)
{
    int rea=n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            rea=rea-rea/i;
            do
                n/=i;
            while(n%i==0);
        }
    }
    if(n>1)
    rea=rea-rea/n;
    return rea;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            break;
        }
        printf("%d\n",phi(n));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值