HDU 5908 Abelian Period(求循环周期,取模优化)【BestCoder Round #88】

109 篇文章 0 订阅
16 篇文章 0 订阅

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=5908

Abelian Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 586 Accepted Submission(s): 247

Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S.

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1.

String u,w are matched if for each number i, occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)≈(1,3,2,1,2).

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k, and all of these substrings are matched with each other.

Now given a string S, please find all of the numbers k that k is a full Abelian period of S.

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n≤100000), denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,…,Sn(1≤Si≤n), denoting the elements of the string.

Output
For each test case, print a line with several integers, denoting all of the number k. You should print them in increasing order.

Sample Input
2
6
5 4 4 4 5 4
8
6 5 6 5 6 5 5 6

Sample Output
3 6
2 4 8

Source
BestCoder Round #88

【中文题意】对于一个数字串SS和一个正整数kk,如果SS可以分成若干个长度为kk的连续子串,且这些子串两两匹配,那么我们称kk是串SS的一个完全阿贝尔周期。
给定一个数字串SS,请找出它所有的完全阿贝尔周期。
【分析】首先SS的长度肯定为kk的倍数,其次,从0 开始,每找连续的kk个数,应该是一样的。所以暴力了一下,用取模来进行优化。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
using namespace std;
#define LL long long

int a[100005],b[100005],c[100005],re[100005];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        int sum=0,flag=0,cnt=0;
        for(int i=1; i<=n; i++)
        {
            if(n%(i)==0&&n/(i)!=1)
            {
                int s=0;
                flag=1;
                for(int j=1; j<=i; j++)
                {
                    b[s++]=a[j];
                }
                sort(b,b+s);
                for(int j=i+1; j<=n; j+=(i))
                {
                    s=0;
                    for(int k=j; k<(j+(i))&&k<=n; k++)
                    {
                        c[s++]=a[k];
                    }
                    if(s!=i)continue;
                    sort(c,c+s);
                    for(int k=0; k<s; k++)
                    {
                        if(b[k]!=c[k])
                        {
                            flag=0;
                            break;
                        }
                    }
                    if(flag==0)
                    {
                        break;
                    }
                }
                if(flag==1)
                {
                    re[cnt++]=i;
                }
            }
        }
        re[cnt++]=n;
        for(int i=0; i<cnt-1; i++)
        {
            printf("%d ",re[i]);
        }
        printf("%d\n",re[cnt-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值