HDU 5907 Find Q (简单题目)【BestCoder Round #88】

题目链接http://acm.split.hdu.edu.cn/showproblem.php?pid=5907

Find Q

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 452 Accepted Submission(s): 236

Problem Description
Byteasar is addicted to the English letter ‘q’. Now he comes across a string S consisting of lowercase English letters.

He wants to find all the continous substrings of S, which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, there is a string S, it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.

Output
For each test case, print a line with an integer, denoting the number of continous substrings of S, which only contain the letter ‘q’.

Sample Input
2
qoder
quailtyqqq

Sample Output
1
7

Source
BestCoder Round #88

【题意】求出连续的且字母全为q的子串的个数有多少个。
【分析】首先分析了一下数据范围,int肯定爆掉,所以果断换了long long 。
长度为n的全为q的字符串的符合条件的子串有n*(n+1)/2个,所以下面就是字符串的分割了,分割完然后求总共符合的个数有多少个。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
using namespace std;
#define LL long long

char a[100005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        LL len=strlen(a),flag=0,s=0;
        LL sum=0;//需要用long long
        for(LL i=0;i<len;i++)
        {
            if(a[i]=='q'&&flag==0)
            {
                flag=1;
                ++s;
                continue;
            }
            else if(a[i]=='q'&&flag==1)
            {
                ++s;
                continue;
            }
            else if(a[i]!='q')
            {
                flag=0;
                sum+=((s*(s+1))/2);
                s=0;
            }
        }
        sum+=((s*(s+1))/2);
        printf("%I64d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值