POJ 3125 Printer Queue(用队列模拟过程)

36 篇文章 0 订阅
32 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3125

Printer Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5001 Accepted: 2600
Description

The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority,
and 1 being the lowest), and the printer operates as follows.
The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.
Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.
Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Sample Output

1
2
5

【思路分析】直接用队列模拟整个打印的过程就好了,看什么时候能打印到所需的材料。

【AC代码】

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<stack>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;

int main()
{
    int n,m,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        queue<int>q,q1;
        int num=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&num);
            q.push(num);
        }
        int flag=1,tt,ti=0,nn=n;
        while(flag)
        {
            num=q.front();
            tt=num;
            q.pop();
            q1.push(num);
            while(!q.empty())
            {
                if(q.front()>num)
                {
                    tt=q.front();
                }
                q1.push(q.front());
                q.pop();
            }
            if(tt==num&&m==0)
            {
                nn--;
                printf("%d\n",ti+1);
                flag=0;
                break;
            }
            else if(tt==num)
            {
                nn--;
                q1.pop();
                ti++;
                while(!q1.empty())
                {
                    q.push(q1.front());
                    q1.pop();
                }
                m--;
                if(m<0)
                {
                    m+=nn;
                }
            }
            else
            {
                m--;
                num=q1.front();
                q1.pop();
                while(!q1.empty())
                {
                    q.push(q1.front());
                    q1.pop();
                }
                q.push(num);
                if(m<0)
                {
                    m+=nn;
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值