POJ 1988 Cube Stacking(并查集+求距离+连通块中元素个数)

36 篇文章 0 订阅
23 篇文章 0 订阅

题目链接:http://poj.org/problem?id=1988
Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 24136 Accepted: 8470
Case Time Limit: 1000MS
Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.
Input

  • Line 1: A single integer, P

  • Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output

Print the output from each of the count operations in the same order as the input file.
Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output

1
0
2
Source

USACO 2004 U S Open

【中文题意】有两种操作。第一种:把x所在的那一列放到y所在的那一列的上面。第二种,求x的下面有多少元素。
【思路分析】用并查集维护每个结点到其根节点的距离,然后用一个数组来维护以每个结点为根节点的连通块中元素的个数。
【AC代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

int pre[30005],d[30005],sum[30005];//d[i]代表的是i节点到其根节点的距离,sum[i]代表的是以i为根节点的连通块中元素的个数

int fin(int x)//找祖先并求出到祖先的距离
{
    if(x!=pre[x])
    {
        int y=pre[x];
        pre[x]=fin(pre[x]);
        d[x]+=d[y];
    }
    return pre[x];
}

void join(int x,int y)//把以x为根节点的连通块加到以y为根节点的连通块上
{
    pre[x]=y;//把x的祖先设为y
    d[x]+=sum[y];//x到当前根节点y的距离要更新
    sum[y]+=sum[x];//以y为根节点的连通块中元素的个数需要更新
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(sum,1,sizeof(sum));
        memset(d,0,sizeof(d));
        for(int i=0;i<=30001;i++)
        {
            pre[i]=i;
            d[i]=0;
            sum[i]=1;
        }
        char c;
        int u,v;
        for(int i=0;i<n;i++)
        {
            cin>>c;
            if(c=='M')
            {
                scanf("%d%d",&u,&v);
                if(fin(u)!=fin(v))
                join(fin(u),fin(v));
            }
            if(c=='C')
            {
                scanf("%d",&u);
                fin(u);
                printf("%d\n",d[u]);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值