POJ 2349 Arctic Network(最小生成树)

题目链接:http://poj.org/problem?id=2349
Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19143 Accepted: 6033
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750
Sample Output

212.13
【中文题意】意思是天上有s颗卫星,地上有p个基站,现给你了p个基站的坐标,每颗卫星可以连接距离为任意大小的两个基站,每两个基站的距离不能超过D,让你求D的最小值。
【思路分析】那么我们可以构造最小生成树,s颗卫星可以代表s个点,既有s-1条边,让后去除最小生成树中这s-1条边之后的最大的边即我们所求的D。
【AC代码】

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;

int pre[1005];

int fin(int x)
{
    if(x==pre[x])
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    if(fin(x)!=fin(y))
    {
        pre[fin(x)]=pre[fin(y)];
    }
}

struct Point
{
    int x,y;
}p[505];

struct node
{
    int u,v;
    double dis;
}e[250005];

bool cmp(node x,node y)
{
    return x.dis<y.dis;
}

bool cmp2(double x,double y)
{
    return x>y;
}

double d[1005];

int main()
{
    int t,s,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&s,&n);
        for(int i=0;i<n;i++)
        {
            pre[i]=i;
            scanf("%d %d",&p[i].x,&p[i].y);
        }
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                e[cnt].u=i;
                e[cnt].v=j;
                e[cnt++].dis=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
                //printf("%f\n",e[cnt-1].dis);
            }
        }
        sort(e,e+cnt,cmp);
        int ss=0,num=0;
        for(int i=0;i<cnt;i++)
        {
            if(fin(e[i].u)!=fin(e[i].v))
            {
                join(e[i].u,e[i].v);
                d[num++]=e[i].dis;
                ss++;
            }
            if(ss==n-1)break;
        }
        sort(d,d+num,cmp2);
        printf("%.2f\n",d[s-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值