POJ 1144 Network(求无向图中的割点)

题目链接:http://poj.org/problem?id=1144
Network
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14502 Accepted: 6601
Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output

The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output

1
2
【中问题意】问你一个无向图中有多少个割点。
输入格式
首先输入n代表这个图中点个个数。
接下来有不确定行输入,直到某行输入的第一个数(且只有一个)为0的时候代表该图结束输入,如果第一个数不为0,则一直输入到换行为止,第一个数与后面的数所代表的点之间都有一条边。
n==0时程序结束。
【思路分析】直接用刘汝佳书上的模板做就好了。就是输入格式有点恶心。
【AC代码】

#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
using namespace std;

vector<int>G[105];//存无向图
int iscut[105],pre[105],low[105];//iscut[i]i点是否为割点,pre[i]当前节点是否被访问过,low[i]为i及i的后代所能连回的最早的祖先的pre值
int dfs_clock;

int dfs(int u,int fa)//u在DFS树中的父节点是fa
{
    int lowu = pre[u] = ++dfs_clock;
    int child = 0;//子节点的数目
    for(int i = 0;i < G[u].size(); i++)
    {
        int v = G[u][i];
        if(!pre[v])//没有访问过v
        {
            child++;
            int lowv = dfs(v,u);
            lowu = min(lowu, lowv);//用后代的low函数更新u的low函数
            if(lowv >= pre[u])
            {
                iscut[u] = true;
            }
        }
        else if(pre[v] < pre[u] && v != fa)//子节点在u之前被访问,并且子节点不是u的父节点
        {
            lowu = min(lowu,pre[v]);//用反向边更新u的low函数
        }
    }
    if(fa < 0 &&child == 1) iscut[u] = 0;//如果u是根节点只有一个子节点的话,那么u一点是割点
    low[u] = lowu;
    return lowu;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
        {
            G[i].clear();
        }
        if(n==0)break;
        int a,b;
        while(scanf("%d",&a)&&a)
        {
            while(getchar()!='\n')
            {
                scanf("%d",&b);
                G[a].push_back(b);
                G[b].push_back(a);
            }
        }
        memset(pre,0,sizeof(pre));
        memset(iscut,0,sizeof(iscut));
        memset(low,0,sizeof(low));
        dfs_clock=0;
        dfs(1,-1);
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(iscut[i])cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值