百练 1013 Counterfeit Dollar

描述

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

输入

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down’’, or ``even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

输出

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

样例输入

12 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 
AGHL BDEC even 
JKI ADE up 
J K even 
ABCDEF GHIJKL up 
ABC DEF even 
I J down 
ABCDEF GHIJKL up 
ABHLEF GDIJKC down 
CD HA even 
A B up 
B A down 
A C even 
A B up 
B C even 
DEFG HIJL even 
ABC DEJ down 
ACH IEF down 
AHK IDJ down 
ABCD EFGH even 
AB IJ even 
A L down 
EFA BGH down 
EFC GHD even 
BA EF down 
A B up 
A C up 
L K even 
ACEGIK BDFHJL up 
ACEGIL BDFHJK down 
ACEGLK BDFHJI down 
ACEGIK BDFHJL up 
ACEGIL BDFHJK down 
ACEGLK BDFHJI up 

样例输出

K is the counterfeit coin and it is light. 
I is the counterfeit coin and it is heavy. 
I is the counterfeit coin and it is light. 
L is the counterfeit coin and it is light. 
B is the counterfeit coin and it is light. 
A is the counterfeit coin and it is heavy. 
A is the counterfeit coin and it is light. 
L is the counterfeit coin and it is heavy. 
A is the counterfeit coin and it is light. 
A is the counterfeit coin and it is heavy. 
L is the counterfeit coin and it is light. 
K is the counterfeit coin and it is heavy.
题意

有十二枚硬币,其中一枚假币与其他真币重量不同,但不知道是轻是重,通过天平称量三次确定这枚硬币的字母代号。

要点

题目中“even”、“up”、“down”三种情况的组合数很大,所以用模拟非常复杂,这里有一个比较特别的技巧
(1)如果天平平衡,那么对应的所有硬币为真,用数组even记录这些硬币。
(2)另设一个数组un,处理even数组中没有记录的硬币,如果是up,那么右盘的硬币怀疑为“轻假币”,对应的un–:而左盘怀疑为“重假币”,对应的un++。如果是down同样这么处理。
(3)最后,un数组中绝对值最大的那个就是假币,大于0的是重币,反之是轻币。

import math

n = int(input())
for _ in range(n):
    a = list(map(str, input().split()))
    b = list(map(str, input().split()))
    c = list(map(str, input().split()))
    even = [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
    un = [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]

    len_a = len(a[0])
    len_b = len(b[0])
    len_c = len(c[0])

    if a[2] == 'even':
        for i in range(len_a):
            even[ord(a[0][i]) - 65] = 1
            even[ord(a[1][i]) - 65] = 1
    if b[2] == 'even':
        for i in range(len_b):
            even[ord(b[0][i]) - 65] = 1
            even[ord(b[1][i]) - 65] = 1
    if c[2] == 'even':
        for i in range(len_c):
            even[ord(c[0][i]) - 65] = 1
            even[ord(c[1][i]) - 65] = 1

    if a[2] == 'up':
        for i in range(len_a):
            if even[ord(a[0][i]) - 65] != 1:
                un[ord(a[0][i]) - 65] += 1
            if even[ord(a[1][i]) - 65] != 1:
                un[ord(a[1][i]) - 65] -= 1
    if b[2] == 'up':
        for i in range(len_b):
            if even[ord(b[0][i]) - 65] != 1:
                un[ord(b[0][i]) - 65] += 1
            if even[ord(b[1][i]) - 65] != 1:
                un[ord(b[1][i]) - 65] -= 1
    if c[2] == 'up':
        for i in range(len_c):
            if even[ord(c[0][i]) - 65] != 1:
                un[ord(c[0][i]) - 65] += 1
            if even[ord(c[1][i]) - 65] != 1:
                un[ord(c[1][i]) - 65] -= 1

    if a[2] == 'down':
        for i in range(len_a):
            if even[ord(a[0][i]) - 65] != 1:
                un[ord(a[0][i]) - 65] -= 1
            if even[ord(a[1][i]) - 65] != 1:
                un[ord(a[1][i]) - 65] += 1
    if b[2] == 'down':
        for i in range(len_b):
            if even[ord(b[0][i]) - 65] != 1:
                un[ord(b[0][i]) - 65] -= 1
            if even[ord(b[1][i]) - 65] != 1:
                un[ord(b[1][i]) - 65] += 1
    if c[2] == 'down':
        for i in range(len_c):
            if even[ord(c[0][i]) - 65] != 1:
                un[ord(c[0][i]) - 65] -= 1
            if even[ord(c[1][i]) - 65] != 1:
                un[ord(c[1][i]) - 65] += 1

    max = -1
    pos = 0
    for i in range(12):
        if max < math.fabs(un[i]):
            max = math.fabs(un[i])
            pos = i
    if un[pos] > 0:
        print(chr(pos + 65), 'is the counterfeit coin and it is heavy.')
    else:
        print(chr(pos + 65), 'is the counterfeit coin and it is light.')
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值