数独

Sudoku Killer

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1218 Accepted Submission(s): 386
 
Problem Description
自从2006年3月10日至11日的首届数独世界锦标赛以后,数独这项游戏越来越受到人们的喜爱和重视。
据说,在2008北京奥运会上,会将数独列为一个单独的项目进行比赛,冠军将有可能获得的一份巨大的奖品———HDU免费七日游外加lcy亲笔签名以及同hdu acm team合影留念的机会。
所以全球人民前仆后继,为了奖品日夜训练茶饭不思。当然也包括初学者linle,不过他太笨了又没有多少耐性,只能做做最最基本的数独题,不过他还是想得到那些奖品,你能帮帮他吗?你只要把答案告诉他就可以,不用教他是怎么做的。

数独游戏的规则是这样的:在一个9x9的方格中,你需要把数字1-9填写到空格当中,并且使方格的每一行和每一列中都包含1-9这九个数字。同时还要保证,空格中用粗线划分成9个3x3的方格也同时包含1-9这九个数字。比如有这样一个题,大家可以仔细观察一下,在这里面每行、每列,以及每个3x3的方格都包含1-9这九个数字。

例题:


答案:
 
Input
本题包含多组测试,每组之间由一个空行隔开。每组测试会给你一个 9*9 的矩阵,同一行相邻的两个元素用一个空格分开。其中1-9代表该位置的已经填好的数,问号(?)表示需要你填的数。
 
Output

            对于每组测试,请输出它的解,同一行相邻的两个数用一个空格分开。两组解之间要一个空行。
对于每组测试数据保证它有且只有一个解。
 
Sample Input
7 1 2 ? 6 ? 3 5 8
? 6 5 2 ? 7 1 ? 4
? ? 8 5 1 3 6 7 2
9 2 4 ? 5 6 ? 3 7
5 ? 6 ? ? ? 2 4 1
1 ? 3 7 2 ? 9 ? 5
? ? 1 9 7 5 4 8 6
6 ? 7 8 3 ? 5 1 9
8 5 9 ? 4 ? ? 2 3
 
Sample Output
7 1 2 4 6 9 3 5 8
3 6 5 2 8 7 1 9 4
4 9 8 5 1 3 6 7 2
9 2 4 1 5 6 8 3 7
5 7 6 3 9 8 2 4 1
1 8 3 7 2 4 9 6 5
2 3 1 9 7 5 4 8 6
6 4 7 8 3 2 5 1 9
8 5 9 6 4 1 7 2 3
#include <iostream>
#include <sstream>
#include <string.h>
#include <cstdio>
#include <string>
#include <cctype>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <cmath>
#define PI acos(-1)
#define ll long long
#define INF 0x7fffffff
#define N 100

using namespace std;

struct Node {
    int x;
    int y;
}node[88];

int G[10][10];
int ok, num;

void print() {
    for (int i = 0; i < 9; i++) {
        for (int j = 0; j < 8; j++) {
            cout << G[i][j] << " ";
        }
        cout << G[i][8] << endl;
    }
}

bool C(int num, int cur) {
    for (int i = 0; i < 9; i++) {
        /// 判断同一列,同一行是否有重复
        if (G[ node[cur].x ][i] == num || G[i][node[cur].y] == num) {
            return false;
        }
    }
    int x = node[cur].x / 3 * 3;
    int y = node[cur].y / 3 * 3;
    /// 判断这个方格是否有重复
    for (int i = 0; i < 3; i++) {
        for (int j = 0; j < 3; j++) {
            if (G[x+i][y+j] == num) {
                return false;
            }
        }
    }
    return true;
}

void dfs(int cur) {
    if (ok == 1) return ;
    if (cur == num) {
        ok = 1;
        print();
        return ;
    }
    for (int i = 1; i <= 9; i++) {
        // cout << i << endl;
        if (C(i, cur)) {
            G[ node[cur].x ][ node[cur].y ] = i;
            dfs(cur+1);
            G[ node[cur].x ][ node[cur].y ] = 0;
        }
    }
    return ;
}

int main() {
    char c;
    char ch[2];
    int T = 0;
    while (cin >> c) {
        num = 0;
        ok = 0;
        memset(G, 0, sizeof(G));
        memset(node, 0, sizeof(node));
        if (c == '?') {
            G[0][0] = 0;
            node[num].x = 0;
            node[num].y = 0;
            num++;
        } else {
            G[0][0] = c - '0';
        }
        for (int i = 0; i < 9; i++) {
            for (int j = 0; j < 9; j++) {
                if (i == 0 && j == 0) continue;
                cin >> c;
                if (c == '?') {
                    G[i][j] = 0;
                    node[num].x = i;
                    node[num].y = j;
                    num++;
                } else {
                    G[i][j] = c - '0';
                }
            }
        }
        if (T++) cout << endl;
        dfs(0);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值