POJ3468 线段树区间维护

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers. 
题意: n个数字组成的序列,q次操作,Q为询问[a,b]的区间和,C为把区间[a,b]内每个值加c。
题解:
Q操作为线段树基本操作,而C操作是线段树最简单一个进阶操作,我们需要给每个节点一个标记add,如果这个节点的区间在a,b内,我们修改这个节点的sum,而对这个节点的子节点不进行修改,当如果需要用到时,再更新,这样大大节约了时间
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 111111
using namespace std;
LL sum[maxn<<2];
LL add[maxn<<2];
void PushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
    if(add[rt])
    {
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=(m-(m>>1))*add[rt];
        sum[rt<<1|1]+=(m>>1)*add[rt];
        add[rt]=0;
    }
}

void build(int l, int r, int rt)//建立线段树
{
    add[rt]=0;
    if (l == r)
    {
        scanf("%I64d", &sum[rt]);
        return;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void update(int L, int R,int c, int l, int r, int rt)
{
    if(L<=l&&R>=r)
    {
        add[rt]+=c;
        sum[rt]+=(LL)c*(r-l+1);
        return ;
    }
    pushdown(rt,r-l+1);
    int m=(r+l)>>1;
    if(L<=m)
        update(L,R,c,lson);
    if(R>m)
        update(L,R,c,rson);
    PushUp(rt);
}

LL query(int L, int R, int l, int r, int rt)//查询线段树
{
    if (L <= l && R>= r) return sum[rt];
    pushdown(rt,r-l+1);
    int m = (l + r) >> 1;
    LL ret = 0;
    if (L<=m) ret += query(L, R, lson);
    if (R>m) ret += query(L, R, rson);
    return ret;
}

int main()
{
    int n,m;
    char d[10];
    scanf("%d%d",&n,&m);
    build(1, n, 1);
    for(int i=0; i<m; i++)
    {
        scanf("%s",d);
        int x,y,z;
        if (d[0] == 'Q')
        {
            scanf("%d%d",&x,&y);
          printf("%I64d\n",query(x,y,1,n,1));
        }
        else
        {
            scanf("%d%d%d",&x,&y,&z);
                update(x,y,z,1,n,1);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值