HDU 5879 Cure(打表)qingdao网赛



Cure
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.

 


Input

There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.


 


Output

The required sum, rounded to the fifth digits after the decimal point.

 


Sample Input

1
2
4
8
15


 


Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

题意:很简单 求1/(1^2)+.......+1/(n^2)的值。

RE 20多发啊,还看什么罚时。。。。好歹还是过了。。。。

题解:

首先知道,你输出进去的是一个字符串,需要把字符串转成 整数(注意前导0的问题),然后需要打一个表,这个表其实不用那么大(我们RE就认为自己的表太小了, 其实是我们不能读入一个很长字符串)。然后判断这个数的大小,如果这个数>655360,就当655360算(别问我咋知道了,玄学)然后按表输出就行了。。。

代码:

#include <iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
char x[10000000];
double a[655360];
inline long long solo()
{
    long long len=strlen(x);
    reverse(x,x+len);
    long long ans=0;
    long long ge=1;
    for(long long i=0; i<len; i++)
    {
        ans+=(x[i]-'0')*ge;
        ge*=10;
        if(ans>=999999)break;
    }
    if(ans>=655359)ans=655359;
    return ans;
}
void inin()
{
    for(register long long bi=2; bi<=655360; bi++)
    {
        double sum=1.0/(bi*bi);
        a[bi]=a[bi-1]+sum;
    }
}
int main()
{
    a[0]=0;
    a[1]=1;
    inin();
    while(~scanf("%s",x))
    {
        long long n=solo();
        printf("%.5lf\n",a[n]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值