HDU Cure

**

HDU Cure

**
题目描述:
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.
Input:
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n.
The input file is at most 1M.
Output
The required sum, rounded to the fifth digits after the decimal point.
Sample Input:
1
2
4
8
15
Sample Output:
1.00000
1.25000
1.42361
1.52742
1.58044
题意:n个数的1/k^2的求和(注意最大的数字是1M所以用字符串进行处理)
难点:在输入数据长度大于6之后,其结果保持不变。

#include<bits/stdc++.h>

using namespace std;

double ans[1000001];

int main() 
{
	ans[1] = 1.00000;
    for(int i=2;i<1000000;i++)
    {
    	ans[i] = ans[i-1] + (1.00000 / i) * (1.00000 / i);
	}
	char a[1000000];
	while(~scanf("%s", a))
	{
		int len = strlen(a);
		if(len > 6)
			cout << "1.64493" << endl;
		else
		{
			int sum = 0;
			for(int i=0;i<strlen(a);i++)
				sum = sum * 10 + (a[i] - '0');
			cout << fixed << setprecision(5) << ans[sum] << endl;			
		}
	}

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Alan wade

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值