POJ 2485(建高速公路__最小生成树)

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30766 Accepted: 13985

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.


我英语差得很,翻译全靠谷歌

这题直接用kruskal就行

我用的优先队列,比较方便,当然换成结构体数组也可以

按照每两个地点之间的权值从小到大排序,如果两个城镇在同一图内(并查集),不连接,否则,将两个端点相连


Tip:一定要注意Hint说的话,数据较多,用scanf输入。。眼残的我一直用cin输入,

报Time Limit Exceeded的错误。错了n次


#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
struct node{
	int x,y,len;
	friend bool operator <(node n1,node n2){
		return n1.len>n2.len;
	}
}; 
int a[1000];
int find(int x){
	if(x != a[x]) a[x] = find(a[x]);
    return a[x];
}
int sum=0;
int main(){
    int n,m;
    scanf("%d",&n);
    while(n--){
    scanf("%d",&m);
    int v[500+3][500+3]={0};
    priority_queue<node>  que;
    for(int i=1;i<=m;i++){
    	a[i]=i;
	}
	for(int i=1;i<=m;i++){
		for(int j=1;j<=m;j++){
			int fz;
			scanf("%d",&fz);
			if(v[i][j]==1||v[j][i]==1||i==j||fz==0)
			continue;
			node de;
			v[i][j]=v[j][i]=1;
			de.x=i;
			de.y=j;
			de.len=fz;
			que.push(de);
		}
	}
	int sum=0;
	while(que.size()){
		node de=que.top();
		que.pop();
		int b1=find(de.x),b2=find(de.y);
		if(b1!=b2){
			a[b1]=b2;
			if(de.len>sum)  sum=de.len;
		}
	}
	cout<<sum<<endl;
	
}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值