Highways
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 27341 | Accepted: 12484 |
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.
Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.
The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1 3 0 990 692 990 0 179 692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.
描述 :有个城市叫做H市。其中有很多个村庄,村庄之间通信基本靠吼,交通基本靠走,很不方便。
这个市长知道了这个情况,为了替市民着想,决定修建高铁。每修建一米花费1美元。
现在市长请了最著名的工程师来修建高铁,自然这个工程师会让修建高铁的费用最少。
不幸的是,在修建了高铁之后就病逝了。现在市长希望知道在修建完成的这些高铁路中最长的一段高铁路花费了多少美元,
他请你来帮助他,如果你计算正确,市长将会送你一辆兰博基尼。
输入:
第一行一个数T,表示接下来有多少组数据。
接下来每组测试数据的第一行有一个数N(3<=N<=500),表示村庄数目。
然后是一个二维数组,第i行第j列表示第i个村庄到第j个村庄的距离。
输出:
只有一个数,输出市长希望知道的已经修成的高铁中最长的路花了多少钱。
最小生成树
#include <stdio.h>
#include <string.h>
int N;
int map[505][505];
int dist[505];
bool vis[505];
int main()
{
int T, i, j, max, t, f;
scanf("%d", &T);
while(T--)
{
scanf("%d", &N);
for(i = 1; i <= N; i++)
{
for(j = 1; j <= N; j++)
{
scanf("%d", &map[i][j]);
}
}
memset(dist, 0x3f, sizeof(dist));
memset(vis, false, sizeof(vis));
dist[1] = 0;
max = 0;
for(i = 1; i <= N; i++)
{
t = 0;
f = 0x3f3f3f3f;
for(j = 1; j <= N; j++)
if(!vis[j] && dist[j] < f)
f = dist[t = j];
if(t == 0) break;
vis[t] = true;
if(max < f)
max = f;
dist[t] = 0;
for(j = 1; j <= N; j++)
if(!vis[j] && map[t][j] < dist[j])
dist[j] = map[t][j];
}
printf("%d\n", max);
}
return 0;
}