[ACM] poj 2485 Highways (最小生成树)

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21056 Accepted: 9723

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU


解题思路:

被这个题的输出格式坑住了。题中明明说每组测试数据后有一空行,结果硬是PE,结果把空行去掉,就AC了。

本题注意的是就是保存哪些边,因为题中n个村庄,给了n*n条边,包括自己跟自己,我们要保存的是n*(n-1)/2条边,比如n=3,保存的是 1->2   1->3    2->3这三条。其它的就是裸最小生成树了,本题要求的是构成最小生成树的所有边中最长的那一条。

代码:

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=125010;
const int N=510;
const int inf=0x7fffffff;
int parent[N];
int t,n;
struct Node
{
    int from,to,edge;
}node[maxn];

void init(int n)
{
    for(int i=1;i<=n;i++)
        parent[i]=i;
}
int find(int x)
{
    return parent[x]==x?x:find(parent[x]);
}
bool cmp(Node a,Node b)
{
    if(a.edge<b.edge)
        return true;
    return false;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int m=0;
        int len;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            scanf("%d",&len);
            if(i<j)
            {
                int temp=m+1;
                node[temp].from=i;
                node[temp].to=j;
                node[temp].edge=len;
                m++;
            }
        }
        m=n*(n-1)/2;
        init(n);
        sort(node+1,node+1+m,cmp);
        len=-inf;
        for(int i=1;i<=m;i++)
        {
            int x=find(node[i].from);
            int y=find(node[i].to);
            if(x==y)
                continue;
            else
            {
                parent[x]=y;
                if(len<node[i].edge)
                    len=node[i].edge;
            }
        }
        printf("%d\n",len);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值