1081. Rational Sum (20)

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
第一次一个点超时。

问题出现在公倍数的寻找上。

看了别人AC代码,发现公倍数直接是分母相乘。

我之前怕会溢出...

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
using namespace std;
long long gcd(long long a,long long b){
	return b==0?a:gcd(b,a%b);
}
long long gbs(long long a,long long b){
	for(int i=max(a,b);i<=a*b;i++){
		if(i%a==0&&i%b==0) return i;
	}
}
int main(){
	int n;
	cin>>n;
	long long suma,sumb;
	scanf("%lld/%lld",&suma,&sumb);
	if(!((suma>0&&sumb>0)||(suma<0&&sumb<0))){
		suma=-1*abs(suma);
		sumb=abs(sumb);
	}
	long long gy=gcd(abs(suma),sumb);
	suma/=gy;
	sumb/=gy;
	for(int i=1;i<n;i++){
		long long a,b;
		scanf("%lld/%lld",&a,&b);
		if(!((a>0&&b>0)||(a<0&&b<0))){
			a=-1*abs(a);
			b=abs(b);
		}
		suma=b*suma;
		a=sumb*a;
		suma+=a;
		sumb=b*sumb;
		long long fz=gcd(abs(suma),sumb);
		suma/=fz;
		sumb/=fz;
	//	cout<<suma<<" "<<sumb<<endl;
	}
	if(sumb==1){
		cout<<suma;
	}
	else{
		if(suma/sumb==1){
			cout<<1;
		}
		else if(suma/sumb==0){
			printf("%d/%d",suma,sumb);
		}
		else{
			printf("%d %d/%d",suma/sumb,suma-(suma/sumb)*sumb,sumb);
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值