PAT A1081

  • 题目:
    Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.
    Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

  • 题目大意
    分数求和,在将和按照一定的格式输出
  • 代码实现
#include <iostream>
#include <cmath>
#include <cstdio>
#include <vector>
using namespace std;
int gcd(int m, int n){
    if(n == 0)
        return m;
    return gcd(n, m % n);
}
struct Fraction{
    int up;                  //分子
    int down;                //分母
};
//分数化简
Fraction reduction(Fraction res){
    if(res.down < 0){
        res.down = -res.down;
        res.up = -res.up;
    }
    if(res.up == 0)
        res.down = 1;
    else {
        int d = gcd(abs(res.up), abs(res.down));
        res.up /=  d;
        res.down /= d;
    }
    return res;
}

//分数加法
Fraction add(Fraction a, Fraction b){
    Fraction res;
    res.up = a.down * b.up + a.up * b.down;
    res.down = a.down * b.down;
    return reduction(res);
}

//分数的输出
void showRes(Fraction r){
    r = reduction(r);
    if(r.down == 1)                         //整数
        printf("%d", r.up);
    else if(abs(r.up) > r.down)            //假分数
        printf("%d %d/%d", r.up / r.down, (int) abs(r.up) % r.down, r.down);
    else                                      //真分数
        printf("%d/%d",r.up, r.down);
}
int main()
{
    int n, up, down;
    char temp;
    cin >> n;
    vector<Fraction> num(n);
    for(int i = 0; i < n; i++){
        scanf("%d%c%d",&up, &temp, &down);
        num[i].up = up;
        num[i].down = down;
        reduction(num[i]);
    }
    Fraction res;
    res.up = 0;
    res.down = 1;
    for(int i = 0; i < n; i++){
        res = add(res, num[i]);
    }
    showRes(res);
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值