(并查集)A Bug's Life -- HDOJ

A Bug’s Life
Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1155 Accepted Submission(s): 428

Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

        The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.

Source
TUD Programming Contest 2005, Darmstadt, Germany

Recommend
linle

思路:
参考链接:http://www.cnblogs.com/bombe1013/p/3781656.html

总的来说就是为每一个 虫子 建立一个集合,这个集合里全部与 该虫子异性,opp[x]的值 表示,x虫子的集合中的根节点,我们举个例子
1 2
1 3
1 4
第一次:opp[1] = 2,opp[2] = 1;
第二次:opp[1] = 3,opp[3] = 1,father[2] = 3;
第三次:opp[1] = 4,opp[4] = 1,father[3] = 4;

我们每更新一对,假设为A B,我们实际上是先找到A的根节点rootA与B的根节点rootB,rootA是A所在集合的根节点,必定在一个集合内,rootB相同
如果rootA与rootB不同的话,就讲rootA归入rootB对立的集合里面,也就是rootA归入到opp[rootB]所在的集合,作为该集合的根节点

如果rootA与rootB相同的话,那么他们就在同一个集合,为同性

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>

using namespace std;
int fa[2005];
int opp[2005];
int flg;
int fid(int x)
{
    if(x != fa[x])
        fa[x] = fid(fa[x]);
    return fa[x];
}

void mer(int x,int y)
{
    int xx = fid(x);
    int yy = fid(y);
    if(xx == yy)
    {
        flg = 0;
        return ;
    }
    if(opp[xx]) fa[opp[xx]] = yy;
    if(opp[yy]) fa[opp[yy]] = xx;
    opp[xx] = yy;
    opp[yy] = xx;
}

int main(void)
{
    int ncase,num=1;
    cin >> ncase;
    while(ncase--)
    {
        int n,m;
        flg = 1;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; ++i)
            fa[i] = i;
        memset(opp,0,sizeof(opp));
        for(int i=0; i<m; ++i)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            mer(u,v);

        }
        printf("Scenario #%d:\n",num++);
        if(!flg)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值