A Bug's Life(并查集拓展)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12358    Accepted Submission(s): 4032


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 
本题大概意思就是:例如给出a和b,表示a与b为异性,判断所给数据是否冲突;
#include<iostream>
#include<stdlib.h>
#define Size 2005
using namespace std;
int father[Size],a[Size],s;
int find(int x){
    if(father[x]==x)
    return x;
    int t = find(father[x]);
    a[x]=(a[x]+a[father[x]])%2;
    father[x] = t;
    return father[x];
}
void merage(int x, int y){
     int fx,fy;
     fx=find(x);
     fy=find(y);   
     if(fx==fy){
        if(a[x]==a[y]){
           s= 1;  //表示冲突
        }
     }
	 else{
        father[fx]=fy;
        a[fx]=(a[x]+a[y]+1)%2;
     }
}
int main()
{
    int b,c,i,n,v,x,y;
    cin>>n;
    v=1;
    while(n--){
        cin>>x>>y;
        for(i=1;i<=x;i++){
            father[i]=i;
            a[i]=0;
        }
        s=0;
        while(y--){	
            cin>>b>>c;
            merage(b,c);
        }
        cout<<"Scenario #"<<v++<<":\n";
        if(s)cout<<"Suspicious bugs found!\n"<<endl;
        else cout<<"No suspicious bugs found!\n"<<endl;
    }
    return 0;
}

大牛详解:

个人认为它是初级并查集问题的一个升级。同时这个题让我看到了食物链的影子。。。
题目的大意是给出n只bug和m次观察到的性行为,并以此为依据判断两只bugs是不是有同性恋行为(gay)。
比如3只bug
1 2有性行为
2 3有性行为
1 3有性行为
---->>>>>首先1,2是异性。
---->>>>>然后2,3是异性。
可以推出1,3是异性。
但是1,3有性行为,所以可以判断出有一定有同性恋。

剥离这个题目所赋予的外壳,我们抽出这个问题的本质:并查集!
其实,这里最重要的是去维护每一个点到集合顶点的偏移量。(注意:下面生造了一个词 所谓集合元素 比如说f[i]=i,那么i就是集合元素,集合偏移量就是集合元素的偏移量)

初始状态下,应该是 
i号点挂在i号集合下面
我们考虑一般情况:假设合并的过程已经进行了一部分 ,这样每一个集合下面都有元素,且各自对于顶点的偏移量都算出来了;
现在在a集合中的元素x和b集合中的元素y进行合并。此时有两中情况改变偏移量;
1.首先是集合的合并,如果要将a,b集合合并,又要保证x,y数字的kind不相同,比如说把b集合挂到a集合下面去。
代表集合的那个元素,他的偏移量永远是0,所以b要改变偏移量,使得b里面的y在进行变换后要和x相异。
如果 kind[x]=0;kind[y]=0;那么y对应的那个代表集合的元素的偏移量必须变成1,因为只有这样才能使得合并后,x,y有不同的kind;
如果 kind[x]=0,kind[y]=1;y对应代表集合的元素偏移量是0,所以对应集合偏移量还是0;
类推   kind[x]=1,kind[y]=0,同上,0;
           kind[x]=1,kind[y]=1,y集合偏移量应该变为1;
综上 可以得到一个同或的关系。
用等式 kind [ a ]=( kind [ x ]+ kind [ y ]+ 1 )% 2 ;恰好满足要求.
2.然后是压缩路径时候的偏移量改变
个人认为,这个主要是解决集合合并时候产生的“残余问题”,因为在合并集合的时候只是考虑了集合的偏移量,至于它下面的元素一概不管。一个压缩路径既分离了父子元素的偏移量,又使得子元素直接指向集合元素。

总而言之,并查集的操作就是不断地维护者各个集合中,每个元素身上对集合元素的偏移关系。从而确定他们是否具有同性恋。
在这个题中,假设是不存在同性恋的,所以只有找到矛盾才输出 有同性恋。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
FileZilla Server 0.9.14a是FileZilla的一个服务器版本。这个版本存在一些bug,以下是一些常见的bug及解决方法: 1. 崩溃:在某些情况下,FileZilla Server 0.9.14a可能会因为一些内部错误而崩溃。要解决这个问题,可以尝试升级到最新版本的FileZilla Server,通常会修复此问题。 2. 无法连接:有时客户端可能无法连接到FileZilla Server。首先,请确保服务器正在运行,并且服务器的端口正确配置。如果问题仍然存在,可以尝试重新启动服务器,并检查防火墙设置。 3. 用户权限问题:有些用户可能报告无法正确访问或修改文件的权限。这可能是由于FileZilla Server的配置错误导致的。建议仔细检查用户的权限设置,确保用户具有所需的访问权限。 4. 传输中断:在某些情况下,传输可能会意外中断,导致文件传输不成功。这可能是由于网络连接不稳定或配置错误引起的。建议使用稳定的网络连接,并确保服务器的传输设置正确。 5. 界面错误:FileZilla Server 0.9.14a的界面可能偶尔出现错误或未响应。这可能是由于软件本身的问题。建议尝试重新启动FileZilla Server,并确保计算机的操作系统和其他软件都是最新版本。 总结来说,FileZilla Server 0.9.14a存在一些已知的bug,但大多数情况下可以通过更新到最新版本、检查配置设置或重启服务器来解决。在遇到问题时,还可以参考FileZilla的官方论坛或在线文档,以获得更多帮助和支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值