poj3061(二分前缀和或者尺取法)

题目:

Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11977 Accepted: 5015
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input:
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output:
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output

2
3

题意:
给一个数列,和一个数s,求数列中最少需要几个数相加得s,可以不连续。

思路一:
二分前缀和,在满足arr[high]-arr[low]>=s这个区间内,二分寻找一个大于等于arr[low]+s的arr[tmp_ans],并且能计算区间长度,那么取所有满足条件的最小值即可。

代码如下:

#include <iostream>
#include <cstring>
#include <algorithm>
const int maxn = 100000+10;
int arr[maxn];

using namespace std;


int main(){
    int t, n, s;
    cin>>t;
    while(t--){
        cin>>n>>s;
        memset(arr, 0, sizeof(arr));
        arr[0]=0;
        for(int i=1; i<=n; i++){
            cin>>arr[i];
            arr[i] = arr[i-1]+arr[i];
        }

        if(arr[n]<s) {cout<<0<<endl; continue;}

        int cnt = s+10;
        int low, high;
        for(int  i=0; arr[n]-arr[i]>=s; i++){
            low = i;
            high = n;
            while(low<=high){
                int mid = (low+high)/2;
                if(arr[mid]>=s+arr[i])
                    high = mid - 1;
                else
                    low = mid + 1;
            }
            cnt = min(cnt, low-i);
        }
        cout<<cnt<<endl;
    }
    return 0;
}

思路2:
尺取法。这个解法我看的这个博客:http://blog.csdn.net/yew1eb/article/details/38776647

我重敲了一遍这个博主的代码,我自己的理解也写在里面了,不重复写了。


#include <iostream>
#include <algorithm>
#include <cstring>
const int maxn = 100000+10;
int arr[maxn];

using namespace std;

int main(){
    int t, n, s;
    cin>>t;
    while(t--){
        cin>>n>>s;
        int ans = s+10;
        for(int i=1; i<=n; i++)
            cin>>arr[i];

        //head表示尺子头,tmp表示尺子长度,cnt计数并且为尺子尾所在
        int head=1, cnt=1, tmp=0;

        while(1){

            //生成尺子(或移动尺子)
            while(cnt<=n&&tmp<s){
                tmp += arr[cnt];
                cnt++;
            }

            //如果生不成尺子,那么结束
            if(tmp<s) break;

            ans = min(ans, cnt-head);

            //将尺子缩短,满足题目尽量小的需要
            tmp -= arr[head++];
        }

        //处理输出
        if(ans<=n) cout<<ans<<endl;
        else cout<<0<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值