poj 3061 Subsequence 二分

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Hint

题意

在一串数组中选择连续段和 这个和要大于等于s 找到这个段满足的最小值 没有的话输出0

题解:

二分 前缀和
一开始竟然在check里暴力搞连续k段和 baka

AC代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <map>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int N = 1e5+5;
int a[N];
int sum[N];
int n,s;
bool check(int k){
    int ans = 0;
    for (int i = 1; i <= n-k+1; ++i){
        ans = sum[i+k-1]-sum[i-1];
         if (ans>=s) return true;
    }
    return false;
}
int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        scanf("%d%d",&n,&s);
        for (int i = 1; i <= n; ++i){
            scanf("%d",&a[i]);
            sum[i] = sum[i-1]+a[i];
        }
        /*长度最大为n 一开始竟然用了N 导致check和判0出了问题 wa了一发*/
        int l = 0,r = n;
        while (l<=r){
            int mid = (l+r)>>1;
            if (!check(mid)) l = mid+1;
            else {
                r = mid-1;
            }
        }

        if (r == n) printf("0\n");
        else printf("%d\n",r+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值