HDU5645(水)

题目:

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1075 Accepted Submission(s): 586

Problem Description
DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A. Next, without putting A back into the box, he randomly picks another ball from the box, and names it B.

If the number written on A is strictly greater than the number on B, he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.

Input
First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n, second line contains n space-separated positive integers ai, denoting the numbers on the balls.

(1≤t≤300,2≤n≤300,1≤ai≤300)

Output
For each testcase, output a real number with 6 decimal places.

Sample Input
2
3
1 2 3
3
100 100 100

Sample Output
0.500000
0.000000

Source
BestCoder Round #76 (div.2)

题意:
t组测试数据,每组一个n,代表这组有多少个数,从这组数中随机选两个,求第一个数大于第二个的概率

思路:
求解这个问题,相当于求出每个有重复的数重复了几次,假设这个数有a个, 那么,将产生a*(a-1)/2个组合,将所有有重复的数产生的组合数想加得到sum,(1-sum/(n*(n-1)/2) )/2就是答案。

小技巧:处理重复出现的数,可以用桶排,加上这里数据范围很小。

#include <iostream>
#include <cstring>
#include <iomanip>
#include <algorithm>
const int maxn = 500;
int arr[maxn];

using namespace std;

int main(){
    int t, n, tmp, low, high;
    cin>>t;
    while(t--){
        cin>>n;
        memset(arr, 0, sizeof(arr));

        cin>>tmp;
        arr[tmp]++;
        low = high = tmp;

        for(int i=1; i<n; i++){
            cin>>tmp;
            arr[tmp]++;
            low = min(low, tmp);
            high = max(high, tmp);
        }

        int tot=0;
        for(int i=low; i<=high; i++){
            tot += arr[i]*(arr[i]-1);
        }
        double ans = 0.5-( tot*1.0/(n*(n-1)) )/2.0;
        cout<<fixed<<ans<<endl;

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值