hdu5645(基础)

43 篇文章 0 订阅

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 152    Accepted Submission(s): 103


Problem Description
DZY loves playing balls.

He has  n  balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it  A . Next, without putting  A  back into the box, he randomly picks another ball from the box, and names it  B .

If the number written on  A  is strictly greater than the number on  B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains  t  denoting the number of testcases.

t  testcases follow. In each testcase, first line contains  n , second line contains  n  space-separated positive integers  ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )
 

Output
For each testcase, output a real number with 6 decimal places. 
 

Sample Input
      
      
2 3 1 2 3 3 100 100 100
 

Sample Output
      
      
0.500000 0.000000
ac代码:
hdu5645 
//有n个球,每个球的编号都不同,现在从中依次拿出两个,问第一个的标号大于第二个的概率是多少?
//首先,将n个球排序,然后循环找出第一次的标号大于第二次的所有方案;除以所有方案数n(n-1)就是答案。 
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	int t,n,i,j,cnt,a[320];
	double result;
	scanf("%d",&t);
	while(t--)
	{
      scanf("%d",&n);
	  for(i=0;i<n;i++)
	   scanf("%d",&a[i]);
	  sort(a,a+n);
	  cnt=0;
	  for(j=n-1;j>=1;j--)
	  {
	  	for(i=j-1;i>=0;i--)
	  	{
	  	  if(a[j]>a[i]) cnt++;	
		}
	  }	
	 result=((double)cnt)/(double)(n*(n-1));
	 printf("%lf\n",result);	
	}
	return 0;
} 

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值